PHP Version wechseln

Aus Plambee.de Webhosting Wiki
Zur Navigation springen Zur Suche springen

Standardmäßig wird Ihr Webspace mit PHP 5.4 betrieben, wenn Sie gerne eine andere Version nutzen möchten, können Sie die Version für Ihren Webspace wechseln.

Unterstützte PHP Versionen

Aktuell laufen auf unseren Servern folgende PHP Versionen:

  • PHP 5.3.29 - wird nicht mehr lange angeboten. Bitte passen Sie Ihre Anwendungen auf neue PHP Versionen an
  • PHP 5.4.45
  • PHP 5.5.37
  • PHP 5.6.26
  • PHP 7.0.11

PHP Version auswählen

PHP Version auswählen

Wenn Sie ihren Webspace mit einer anderen PHP Version als PHP 5.4 betreiben möchten, können Sie die PHP Version im Usercp für jede (Sub-)Domain einzeln auswählen. Wählen Sie hierfür bitte im Usercp den Punkt "Domains" aus und klicken dann die zu bearbeitende (Sub-)Domain aus. Hier sehen Sie nun eine Drop-Down Liste mit der Sie die PHP Version auswählen können.
Nach dem Klick auf speichern dauert es noch ein paar Sekunden und die PHP Version wird für die gewählte (Sub-)Domain geändert.

Hinweis zu PHP 5.2 und älter

Auch wenn es immer wieder Anfragen zu PHP 5.2 und älter gibt, diese Versionen werden wir NICHT unterstützen da Sie zu alt sind und keine Sicherheitsupdates mehr bekommen. Aus unserer Sicht wäre der Einsatz einer solchen Version zur gefährlich und leichtsinnig. Sollten Sie dennoch eine nicht mehr unterstützte PHP Version einsetzen wollen, schauen Sie sich unsere vServer an. Hier können Sie selbst bestimmen welche Software Sie installieren. Seien Sie sich beim Einsatz alter Software bitte den Risiken bewusst.